So I went into record mode (Record LED came on) and tried to enter DMX assign mode (REC+666) but nothing changed: display shows fader percentage (00). Up/Down buttons do nothing. Pressing "Rec" increments a number on the display. Tried DMX reset (REC+777) which worked but assign still doesn't work.
The 6 button works correctly as it's needed to enter record mode.

So now I've reset the DMX assignments and can't set it back! Any suggestions welcome.

Desk is 24 channel SceneSetter with the square buttons
Original Post
Hello benben,

what are you attempting to do? What did you need with the assignments? Maybe we can figure out an alternative solution. Please email me, Thanks!
I'm attempting to follow the instructions in the manual under section 3.7 DMX Channel Setup.

We have 6 channels of house lights which were previously all assigned to channel 1 before I reset it. I would like to restore this.

Does the desk need resetting or refurbishing? Or am I doing something wrong?
Are you using a Dimmer Pack? Please send me a response email, I will be able to be more attentive and direct through that. Thanks!
I'm not sure what brand the dimmers are, but they are 12 channel. The start address of the one that does house lights is 1, the stage light dimmer starts at 13.

I've sent you an email.
Hello, I know, this thread is older , but find nowhere a solution.
I`ve exact the same problem. Can`t assign dmx-adresses to faders.
I think, the information in the manual are wrong.
(Even edit-modus code is not 1 6 6 8, but 1 5 6 8).
Can you post a correct list Smiler ?

Benben... I also have been dealing with DMX addressing. My board is new. I did find i the manual (3.7)while in the record mode to hold record and then hit the #6 flash button 3 times which does not work. I did see, however, on the bottom of my controller that to enter the DMX addressing you have to hit Flash 8 (not 6) three times ..... The does allow me to enter the DMX channel addressing but I find nowhere how to program it in... I believe my unit is defective and I am in the process of getting a replacement.

Add Reply

Link copied to your clipboard.