Skip to main content

Hello guys!
Does anyone had this problem: when you plug the rj45 to AR-32C all channels go in off mode. buttons seems to be alive (you can select different shows but looks like nothing is going out). I have tried with another AR-32C unit and is working well. So probably my initial AR-32C is faulty (or wrongly flashed?). I've tried to install latest software 3.01 on my XP from here but looks like USB driver for ncw_dmx20 is not correct. Also when try to run AR-32 software have this error: Can't Load ft8u245.dll . Any ideas?
Original Post

Replies sorted oldest to newest

tried the drivers you sent me still no luck so decided to open up the control panel and found that the micro usb slot looks like its been replaced at some point in doing this thow they have damaged the track on another part of the pcb and tried repairing it badly so probably explained why none of the drivers seem to be working but thank you for your help it is really appreciated don’t suppose if you know if there is anywhere that i could get a replacement control panel from?
Originally posted by RC:
What version of the software are you running? Have you tried uninstalling the software and reinstalling it? I run my AR-32 here on a 32 bit XP here, that should be fine. Let me hnow when you have a chance and we will go from there.


I'm running version 3.05. When the device is plugged in it also says it is missing the driver for device ncw_dmx20 in device manager... I have also tried uninstalling and reinstalling. Any more suggestions?

Add Reply

Link copied to your clipboard.